3

Currently I saw a new question at Meta and wanted to login here. I'm using Tor Browser 4.5.1 or 5.0.1-alpha and was not able to login to the site. It works without any problems at the main site. But when I change to Meta and click on log in I am redirected to the previous site without getting logged in. I tried the same with Firefox 38. It worked with or without HTTPS Everywhere installed.

Could anyone help to track down this issue and to change the page that the login process works again?

4

We support the mainstream browsers out there, going a version or two back from current. Tor Browser doesn't really make the list.

HTTPS Everywhere could also certainly throw a wrench into this, but if it's off and you're also seeing this behaviour in Firefox... Hmm.

Do other browsers (e.g. Chrome) work fine? We've seen an issue in Firefox specifically that we haven't been able to reproduce or track down where it just stops allowing folks to log in. Clearing the cache, cookies, and (oddly enough) browsing history for the Q&A sites as well as stackauth.com has been known to help.

Having said all that, there is no separate login for a child meta site. Your credentials are inherited from the parent main site. So if you're logged in there, you should be logged in by default on the meta site as well.

  • 2
    Thanks for your answer. However I expect this are somehow bad news for our users. Most of them come from check.torproject.org or similar sites and I assume that the majority is using Tor Browser. While they currently can use Tor.SE, they won't be able to use the Meta as logged-in user (or even is it in a secure way with HTTPS). Both worked some weeks ago. – Jens Kubieziel Jun 12 '15 at 20:39
  • 1
    As far as I understand the threat model of Tor Browser it should not allow such a "re-use" of credentials. Thatswhy one has to log in at the first visit of another SE site (Meta as well as a completely other SE site). – Jens Kubieziel Jun 12 '15 at 20:41
4

I dug a little bit more into the issue. It seems that it is indeed an issue with HTTPS Everywhere. When I disable HTTPS Everywhere for Stackexchange and manually select https://meta.tor.stackexchange.com I'm able to log in. So I'll make a ticket for HTTPS Everywhere and hope it will be fixed in the future.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .